Welcome & Happy Holidays!
Kết quả 1 đến 9 của 9
  1. #1
    Ngày tham gia
    Sep 2015
    Bài viết
    0

    Lỗi ic 4001 không giữ trạng thái

    Mình có làm cái mạch remote để điều khiển đảo chiều động cơ DC.mạch remote mình dùng ic 2248 và mạch thu dùng 2249.mình test trên board thì thấy 2 mạch này hoạt động tốt nhưng vấn đề là mình ko thể giữ dc trạng thái sau khi nhấn nút bất kỳ cho đến khi nhấn nút thứ 2.có nghĩa là mình nhấn nút quay trái thì động cơ quay trái nhưng sau đó động cơ không quay nữa.mình muốn sao khi nhấn quay trái thì thả ra động cơ vẫn quay và khi nhấn nút quay phải động cơ sẽ đảo chiều.v..v.mạch chốt mình dùng con ic4001(tích hợp các cổng NOR 2ngõ vào)nhưng không thể giữ trạng thái được.mặc dù mình cũng cấp Vss cho ic nhưng khi nhấn led báo chỉ sánh rồi tắt nhanh.trạng thái này cũng y như khi ko cấp vss cho ic.Minh đang rấy đau đầu về vấn đề này.mạch động cơ mình dùng mạch cầu H.rất mong các bác có kinh nghiệm giúp đỡ ....

  2. #2
    Ngày tham gia
    Sep 2015
    Bài viết
    0
    Bạn có sơ đồ không?

  3. #3
    Ngày tham gia
    May 2016
    Bài viết
    0
    Trích dẫn Gửi bởi yeuthichdientu
    Bạn có sơ đồ không?
    cụ thể mình làm như sơ đồ này nè bạn.Mình thử trên test board thôi,các trạng thái ở ngõ ra đều đúng khi còn nguồn áp duy trì vào điểm đó nhưng khi ngưng cấp nguồn thì trạng thái không còn dc giữ như trong sơ đồ mô phỏng nữa.Mình thử cấp nguồn cho chân số 14 (Vss) của IC 4001là 6V nhưng vẫn không dc mặc dù trong Proteus mình mô phỏng vẫn chạy đúng như mong muốn là ngừng cấp nguồn tín hiệu vẫn có áp duy trì trạng thái ở đầu ra.
    Và một điều nữa là không biết là chân 14 của IC có mặc điịnh nối nguồn không mà mình lôi hết các chân IC ra mà vẫn không thấy dc chân 7 và 14.Khi mình chuyển sang vẽ mạch in thì chỉ có chân 7 nối mass còn chân 14 thì không(chỉ nằm không,không có liên kết với linh kiện nào hết)...giải thích giúp mình với.


    [IMG]http://*************/attachments/42860/[/IMG]

  4. #4
    Ngày tham gia
    Sep 2015
    Bài viết
    0
    Trích dẫn Gửi bởi Kiếm Định
    cụ thể mình làm như sơ đồ này nè bạn.Mình thử trên test board thôi,các trạng thái ở ngõ ra đều đúng khi còn nguồn áp duy trì vào điểm đó nhưng khi ngưng cấp nguồn thì trạng thái không còn dc giữ như trong sơ đồ mô phỏng nữa.Mình thử cấp nguồn cho chân số 14 (Vss) của IC 4001là 6V nhưng vẫn không dc mặc dù trong Proteus mình mô phỏng vẫn chạy đúng như mong muốn là ngừng cấp nguồn tín hiệu vẫn có áp duy trì trạng thái ở đầu ra.
    Và một điều nữa là không biết là chân 14 của IC có mặc điịnh nối nguồn không mà mình lôi hết các chân IC ra mà vẫn không thấy dc chân 7 và 14.Khi mình chuyển sang vẽ mạch in thì chỉ có chân 7 nối mass còn chân 14 thì không(chỉ nằm không,không có liên kết với linh kiện nào hết)...giải thích giúp mình với.


    [IMG]http://*************/attachments/42860/[/IMG]
    - nhưng khi ngưng cấp nguồn thì trạng thái không còn dc giữ
    Ngưng cấp cho đầu vào R/S hay ngưng cấp cho IC 4001 ?

    - thử cấp nguồn cho chân số 14
    Đương nhiên là phải cấp nguồn IC mới chạy, chân 14 = (+), chân 7 =GND

    - Khi mình chuyển sang vẽ mạch in thì chỉ có chân 7 nối mass còn chân 14 thì không
    Bạn phải tự nối đến +V (nếu không tự động được)

  5. #5
    Ngày tham gia
    Apr 2016
    Bài viết
    0
    Trích dẫn Gửi bởi yeuthichdientu
    - nhưng khi ngưng cấp nguồn thì trạng thái không còn dc giữ
    Ngưng cấp cho đầu vào R/S hay ngưng cấp cho IC 4001 ?

    - thử cấp nguồn cho chân số 14
    Đương nhiên là phải cấp nguồn IC mới chạy, chân 14 = (+), chân 7 =GND

    - Khi mình chuyển sang vẽ mạch in thì chỉ có chân 7 nối mass còn chân 14 thì không
    Bạn phải tự nối đến +V (nếu không tự động được)
    Mình ngưng cấp tín hiệu đó.còn chân 14 thì cấp với ko cấp cũng ko thấy tác dụng gì hết..mạch ko giữ dc trạng thái ngõ ra đó.

  6. #6
    Ngày tham gia
    Sep 2015
    Bài viết
    0
    Bạn đang nói về mạch thật hay mô phỏng vậy?

  7. #7
    Ngày tham gia
    Sep 2015
    Bài viết
    0
    Trích dẫn Gửi bởi yeuthichdientu
    Bạn đang nói về mạch thật hay mô phỏng vậy?
    mạch thật đó bạn

  8. #8
    Ngày tham gia
    Sep 2015
    Bài viết
    0
    Vậy thì 1- dứt khoát là phải cấp nguồn rồi. 2 - là nối trở 47-100k từ R và S xuống GND. 3 - Nếu vẫn bị thế thì thay IC khác xem.

  9. #9
    Ngày tham gia
    Sep 2015
    Bài viết
    0
    Trích dẫn Gửi bởi yeuthichdientu
    Vậy thì 1- dứt khoát là phải cấp nguồn rồi. 2 - là nối trở 47-100k từ R và S xuống GND. 3 - Nếu vẫn bị thế thì thay IC khác xem.
    hi..e lam dc roi bac ak..cam on bac nhieu lam

 

 

Quyền viết bài

  • Bạn Không thể gửi Chủ đề mới
  • Bạn Không thể Gửi trả lời
  • Bạn Không thể Gửi file đính kèm
  • Bạn Không thể Sửa bài viết của mình
  •  
Múi giờ GMT +7. Bây giờ là 05:00 PM. Diễn đàn sử dụng vBulletin® Phiên bản 4.2.5.
Bản quyền của 2024 vBulletin Solutions, Inc. Tất cả quyền được bảo lưu.
Ban quản trị không chịu trách nhiệm về nội dung do thành viên đăng.